{ "_readme": [ "This file locks the dependencies of your project to a known state", "Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies", "This file is @generated automatically" ], "content-hash": "318aa13021644c16a9c73ae62ca46f53", "packages": [ { "name": "brick/math", "version": "0.11.0", "source": { "type": "git", "url": "https://github.com/brick/math.git", "reference": "0ad82ce168c82ba30d1c01ec86116ab52f589478" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/brick/math/zipball/0ad82ce168c82ba30d1c01ec86116ab52f589478", "reference": "0ad82ce168c82ba30d1c01ec86116ab52f589478", "shasum": "" }, "require": { "php": "^8.0" }, "require-dev": { "php-coveralls/php-coveralls": "^2.2", "phpunit/phpunit": "^9.0", "vimeo/psalm": "5.0.0" }, "type": "library", "autoload": { "psr-4": { "Brick\\Math\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "description": "Arbitrary-precision arithmetic library", "keywords": [ "Arbitrary-precision", "BigInteger", "BigRational", "arithmetic", "bigdecimal", "bignum", "brick", "math" ], "support": { "issues": "https://github.com/brick/math/issues", "source": "https://github.com/brick/math/tree/0.11.0" }, "funding": [ { "url": "https://github.com/BenMorel", "type": "github" } ], "time": "2023-01-15T23:15:59+00:00" }, { "name": "guzzlehttp/guzzle", "version": "7.8.0", "source": { "type": "git", "url": "https://github.com/guzzle/guzzle.git", "reference": "1110f66a6530a40fe7aea0378fe608ee2b2248f9" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/guzzle/guzzle/zipball/1110f66a6530a40fe7aea0378fe608ee2b2248f9", "reference": "1110f66a6530a40fe7aea0378fe608ee2b2248f9", "shasum": "" }, "require": { "ext-json": "*", "guzzlehttp/promises": "^1.5.3 || ^2.0.1", "guzzlehttp/psr7": "^1.9.1 || ^2.5.1", "php": "^7.2.5 || ^8.0", "psr/http-client": "^1.0", "symfony/deprecation-contracts": "^2.2 || ^3.0" }, "provide": { "psr/http-client-implementation": "1.0" }, "require-dev": { "bamarni/composer-bin-plugin": "^1.8.1", "ext-curl": "*", "php-http/client-integration-tests": "dev-master#2c025848417c1135031fdf9c728ee53d0a7ceaee as 3.0.999", "php-http/message-factory": "^1.1", "phpunit/phpunit": "^8.5.29 || ^9.5.23", "psr/log": "^1.1 || ^2.0 || ^3.0" }, "suggest": { "ext-curl": "Required for CURL handler support", "ext-intl": "Required for Internationalized Domain Name (IDN) support", "psr/log": "Required for using the Log middleware" }, "type": "library", "extra": { "bamarni-bin": { "bin-links": true, "forward-command": false } }, "autoload": { "files": [ "src/functions_include.php" ], "psr-4": { "GuzzleHttp\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Graham Campbell", "email": "hello@gjcampbell.co.uk", "homepage": "https://github.com/GrahamCampbell" }, { "name": "Michael Dowling", "email": "mtdowling@gmail.com", "homepage": "https://github.com/mtdowling" }, { "name": "Jeremy Lindblom", "email": "jeremeamia@gmail.com", "homepage": "https://github.com/jeremeamia" }, { "name": "George Mponos", "email": "gmponos@gmail.com", "homepage": "https://github.com/gmponos" }, { "name": "Tobias Nyholm", "email": "tobias.nyholm@gmail.com", "homepage": "https://github.com/Nyholm" }, { "name": "Márk Sági-Kazár", "email": "mark.sagikazar@gmail.com", "homepage": "https://github.com/sagikazarmark" }, { "name": "Tobias Schultze", "email": "webmaster@tubo-world.de", "homepage": "https://github.com/Tobion" } ], "description": "Guzzle is a PHP HTTP client library", "keywords": [ "client", "curl", "framework", "http", "http client", "psr-18", "psr-7", "rest", "web service" ], "support": { "issues": "https://github.com/guzzle/guzzle/issues", "source": "https://github.com/guzzle/guzzle/tree/7.8.0" }, "funding": [ { "url": "https://github.com/GrahamCampbell", "type": "github" }, { "url": "https://github.com/Nyholm", "type": "github" }, { "url": "https://tidelift.com/funding/github/packagist/guzzlehttp/guzzle", "type": "tidelift" } ], "time": "2023-08-27T10:20:53+00:00" }, { "name": "guzzlehttp/promises", "version": "2.0.1", "source": { "type": "git", "url": "https://github.com/guzzle/promises.git", "reference": "111166291a0f8130081195ac4556a5587d7f1b5d" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/guzzle/promises/zipball/111166291a0f8130081195ac4556a5587d7f1b5d", "reference": "111166291a0f8130081195ac4556a5587d7f1b5d", "shasum": "" }, "require": { "php": "^7.2.5 || ^8.0" }, "require-dev": { "bamarni/composer-bin-plugin": "^1.8.1", "phpunit/phpunit": "^8.5.29 || ^9.5.23" }, "type": "library", "extra": { "bamarni-bin": { "bin-links": true, "forward-command": false } }, "autoload": { "psr-4": { "GuzzleHttp\\Promise\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Graham Campbell", "email": "hello@gjcampbell.co.uk", "homepage": "https://github.com/GrahamCampbell" }, { "name": "Michael Dowling", "email": "mtdowling@gmail.com", "homepage": "https://github.com/mtdowling" }, { "name": "Tobias Nyholm", "email": "tobias.nyholm@gmail.com", "homepage": "https://github.com/Nyholm" }, { "name": "Tobias Schultze", "email": "webmaster@tubo-world.de", "homepage": "https://github.com/Tobion" } ], "description": "Guzzle promises library", "keywords": [ "promise" ], "support": { "issues": "https://github.com/guzzle/promises/issues", "source": "https://github.com/guzzle/promises/tree/2.0.1" }, "funding": [ { "url": "https://github.com/GrahamCampbell", "type": "github" }, { "url": "https://github.com/Nyholm", "type": "github" }, { "url": "https://tidelift.com/funding/github/packagist/guzzlehttp/promises", "type": "tidelift" } ], "time": "2023-08-03T15:11:55+00:00" }, { "name": "guzzlehttp/psr7", "version": "2.6.1", "source": { "type": "git", "url": "https://github.com/guzzle/psr7.git", "reference": "be45764272e8873c72dbe3d2edcfdfcc3bc9f727" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/guzzle/psr7/zipball/be45764272e8873c72dbe3d2edcfdfcc3bc9f727", "reference": "be45764272e8873c72dbe3d2edcfdfcc3bc9f727", "shasum": "" }, "require": { "php": "^7.2.5 || ^8.0", "psr/http-factory": "^1.0", "psr/http-message": "^1.1 || ^2.0", "ralouphie/getallheaders": "^3.0" }, "provide": { "psr/http-factory-implementation": "1.0", "psr/http-message-implementation": "1.0" }, "require-dev": { "bamarni/composer-bin-plugin": "^1.8.1", "http-interop/http-factory-tests": "^0.9", "phpunit/phpunit": "^8.5.29 || ^9.5.23" }, "suggest": { "laminas/laminas-httphandlerrunner": "Emit PSR-7 responses" }, "type": "library", "extra": { "bamarni-bin": { "bin-links": true, "forward-command": false } }, "autoload": { "psr-4": { "GuzzleHttp\\Psr7\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Graham Campbell", "email": "hello@gjcampbell.co.uk", "homepage": "https://github.com/GrahamCampbell" }, { "name": "Michael Dowling", "email": "mtdowling@gmail.com", "homepage": "https://github.com/mtdowling" }, { "name": "George Mponos", "email": "gmponos@gmail.com", "homepage": "https://github.com/gmponos" }, { "name": "Tobias Nyholm", "email": "tobias.nyholm@gmail.com", "homepage": "https://github.com/Nyholm" }, { "name": "Márk Sági-Kazár", "email": "mark.sagikazar@gmail.com", "homepage": "https://github.com/sagikazarmark" }, { "name": "Tobias Schultze", "email": "webmaster@tubo-world.de", "homepage": "https://github.com/Tobion" }, { "name": "Márk Sági-Kazár", "email": "mark.sagikazar@gmail.com", "homepage": "https://sagikazarmark.hu" } ], "description": "PSR-7 message implementation that also provides common utility methods", "keywords": [ "http", "message", "psr-7", "request", "response", "stream", "uri", "url" ], "support": { "issues": "https://github.com/guzzle/psr7/issues", "source": "https://github.com/guzzle/psr7/tree/2.6.1" }, "funding": [ { "url": "https://github.com/GrahamCampbell", "type": "github" }, { "url": "https://github.com/Nyholm", "type": "github" }, { "url": "https://tidelift.com/funding/github/packagist/guzzlehttp/psr7", "type": "tidelift" } ], "time": "2023-08-27T10:13:57+00:00" }, { "name": "minishlink/web-push", "version": "v8.0.0", "source": { "type": "git", "url": "https://github.com/web-push-libs/web-push-php.git", "reference": "ec034f1e287cd1e74235e349bd017d71a61e9d8d" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/web-push-libs/web-push-php/zipball/ec034f1e287cd1e74235e349bd017d71a61e9d8d", "reference": "ec034f1e287cd1e74235e349bd017d71a61e9d8d", "shasum": "" }, "require": { "ext-curl": "*", "ext-json": "*", "ext-mbstring": "*", "ext-openssl": "*", "guzzlehttp/guzzle": "^7.0.1|^6.2", "php": ">=8.0", "spomky-labs/base64url": "^2.0", "web-token/jwt-key-mgmt": "^2.0|^3.0.2", "web-token/jwt-signature": "^2.0|^3.0.2", "web-token/jwt-signature-algorithm-ecdsa": "^2.0|^3.0.2", "web-token/jwt-util-ecc": "^2.0|^3.0.2" }, "require-dev": { "friendsofphp/php-cs-fixer": "^v3.13.2", "phpstan/phpstan": "^1.9.8", "phpunit/phpunit": "^9.5.27" }, "suggest": { "ext-gmp": "Optional for performance." }, "type": "library", "autoload": { "psr-4": { "Minishlink\\WebPush\\": "src" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Louis Lagrange", "email": "lagrange.louis@gmail.com", "homepage": "https://github.com/Minishlink" } ], "description": "Web Push library for PHP", "homepage": "https://github.com/web-push-libs/web-push-php", "keywords": [ "Push API", "WebPush", "notifications", "push", "web" ], "support": { "issues": "https://github.com/web-push-libs/web-push-php/issues", "source": "https://github.com/web-push-libs/web-push-php/tree/v8.0.0" }, "time": "2023-01-10T17:14:44+00:00" }, { "name": "paragonie/constant_time_encoding", "version": "v2.6.3", "source": { "type": "git", "url": "https://github.com/paragonie/constant_time_encoding.git", "reference": "58c3f47f650c94ec05a151692652a868995d2938" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/paragonie/constant_time_encoding/zipball/58c3f47f650c94ec05a151692652a868995d2938", "reference": "58c3f47f650c94ec05a151692652a868995d2938", "shasum": "" }, "require": { "php": "^7|^8" }, "require-dev": { "phpunit/phpunit": "^6|^7|^8|^9", "vimeo/psalm": "^1|^2|^3|^4" }, "type": "library", "autoload": { "psr-4": { "ParagonIE\\ConstantTime\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Paragon Initiative Enterprises", "email": "security@paragonie.com", "homepage": "https://paragonie.com", "role": "Maintainer" }, { "name": "Steve 'Sc00bz' Thomas", "email": "steve@tobtu.com", "homepage": "https://www.tobtu.com", "role": "Original Developer" } ], "description": "Constant-time Implementations of RFC 4648 Encoding (Base-64, Base-32, Base-16)", "keywords": [ "base16", "base32", "base32_decode", "base32_encode", "base64", "base64_decode", "base64_encode", "bin2hex", "encoding", "hex", "hex2bin", "rfc4648" ], "support": { "email": "info@paragonie.com", "issues": "https://github.com/paragonie/constant_time_encoding/issues", "source": "https://github.com/paragonie/constant_time_encoding" }, "time": "2022-06-14T06:56:20+00:00" }, { "name": "psr/http-client", "version": "1.0.3", "source": { "type": "git", "url": "https://github.com/php-fig/http-client.git", "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/php-fig/http-client/zipball/bb5906edc1c324c9a05aa0873d40117941e5fa90", "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90", "shasum": "" }, "require": { "php": "^7.0 || ^8.0", "psr/http-message": "^1.0 || ^2.0" }, "type": "library", "extra": { "branch-alias": { "dev-master": "1.0.x-dev" } }, "autoload": { "psr-4": { "Psr\\Http\\Client\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "PHP-FIG", "homepage": "https://www.php-fig.org/" } ], "description": "Common interface for HTTP clients", "homepage": "https://github.com/php-fig/http-client", "keywords": [ "http", "http-client", "psr", "psr-18" ], "support": { "source": "https://github.com/php-fig/http-client" }, "time": "2023-09-23T14:17:50+00:00" }, { "name": "psr/http-factory", "version": "1.0.2", "source": { "type": "git", "url": "https://github.com/php-fig/http-factory.git", "reference": "e616d01114759c4c489f93b099585439f795fe35" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/php-fig/http-factory/zipball/e616d01114759c4c489f93b099585439f795fe35", "reference": "e616d01114759c4c489f93b099585439f795fe35", "shasum": "" }, "require": { "php": ">=7.0.0", "psr/http-message": "^1.0 || ^2.0" }, "type": "library", "extra": { "branch-alias": { "dev-master": "1.0.x-dev" } }, "autoload": { "psr-4": { "Psr\\Http\\Message\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "PHP-FIG", "homepage": "https://www.php-fig.org/" } ], "description": "Common interfaces for PSR-7 HTTP message factories", "keywords": [ "factory", "http", "message", "psr", "psr-17", "psr-7", "request", "response" ], "support": { "source": "https://github.com/php-fig/http-factory/tree/1.0.2" }, "time": "2023-04-10T20:10:41+00:00" }, { "name": "psr/http-message", "version": "2.0", "source": { "type": "git", "url": "https://github.com/php-fig/http-message.git", "reference": "402d35bcb92c70c026d1a6a9883f06b2ead23d71" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/php-fig/http-message/zipball/402d35bcb92c70c026d1a6a9883f06b2ead23d71", "reference": "402d35bcb92c70c026d1a6a9883f06b2ead23d71", "shasum": "" }, "require": { "php": "^7.2 || ^8.0" }, "type": "library", "extra": { "branch-alias": { "dev-master": "2.0.x-dev" } }, "autoload": { "psr-4": { "Psr\\Http\\Message\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "PHP-FIG", "homepage": "https://www.php-fig.org/" } ], "description": "Common interface for HTTP messages", "homepage": "https://github.com/php-fig/http-message", "keywords": [ "http", "http-message", "psr", "psr-7", "request", "response" ], "support": { "source": "https://github.com/php-fig/http-message/tree/2.0" }, "time": "2023-04-04T09:54:51+00:00" }, { "name": "ralouphie/getallheaders", "version": "3.0.3", "source": { "type": "git", "url": "https://github.com/ralouphie/getallheaders.git", "reference": "120b605dfeb996808c31b6477290a714d356e822" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/ralouphie/getallheaders/zipball/120b605dfeb996808c31b6477290a714d356e822", "reference": "120b605dfeb996808c31b6477290a714d356e822", "shasum": "" }, "require": { "php": ">=5.6" }, "require-dev": { "php-coveralls/php-coveralls": "^2.1", "phpunit/phpunit": "^5 || ^6.5" }, "type": "library", "autoload": { "files": [ "src/getallheaders.php" ] }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Ralph Khattar", "email": "ralph.khattar@gmail.com" } ], "description": "A polyfill for getallheaders.", "support": { "issues": "https://github.com/ralouphie/getallheaders/issues", "source": "https://github.com/ralouphie/getallheaders/tree/develop" }, "time": "2019-03-08T08:55:37+00:00" }, { "name": "spomky-labs/base64url", "version": "v2.0.4", "source": { "type": "git", "url": "https://github.com/Spomky-Labs/base64url.git", "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d", "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d", "shasum": "" }, "require": { "php": ">=7.1" }, "require-dev": { "phpstan/extension-installer": "^1.0", "phpstan/phpstan": "^0.11|^0.12", "phpstan/phpstan-beberlei-assert": "^0.11|^0.12", "phpstan/phpstan-deprecation-rules": "^0.11|^0.12", "phpstan/phpstan-phpunit": "^0.11|^0.12", "phpstan/phpstan-strict-rules": "^0.11|^0.12" }, "type": "library", "autoload": { "psr-4": { "Base64Url\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Florent Morselli", "homepage": "https://github.com/Spomky-Labs/base64url/contributors" } ], "description": "Base 64 URL Safe Encoding/Decoding PHP Library", "homepage": "https://github.com/Spomky-Labs/base64url", "keywords": [ "base64", "rfc4648", "safe", "url" ], "support": { "issues": "https://github.com/Spomky-Labs/base64url/issues", "source": "https://github.com/Spomky-Labs/base64url/tree/v2.0.4" }, "funding": [ { "url": "https://github.com/Spomky", "type": "github" }, { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2020-11-03T09:10:25+00:00" }, { "name": "spomky-labs/pki-framework", "version": "1.1.0", "source": { "type": "git", "url": "https://github.com/Spomky-Labs/pki-framework.git", "reference": "d3ba688bf40e7c6e0dabf065ee18fc210734e760" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/Spomky-Labs/pki-framework/zipball/d3ba688bf40e7c6e0dabf065ee18fc210734e760", "reference": "d3ba688bf40e7c6e0dabf065ee18fc210734e760", "shasum": "" }, "require": { "brick/math": "^0.10 || ^0.11", "ext-mbstring": "*", "php": ">=8.1" }, "require-dev": { "ekino/phpstan-banned-code": "^1.0", "ext-gmp": "*", "ext-openssl": "*", "infection/infection": "^0.26", "php-parallel-lint/php-parallel-lint": "^1.3", "phpstan/phpstan": "^1.8", "phpstan/phpstan-beberlei-assert": "^1.0", "phpstan/phpstan-deprecation-rules": "^1.0", "phpstan/phpstan-phpunit": "^1.1", "phpstan/phpstan-strict-rules": "^1.3", "phpunit/phpunit": "^10.0", "rector/rector": "^0.15", "roave/security-advisories": "dev-latest", "symfony/phpunit-bridge": "^6.1", "symfony/var-dumper": "^6.1", "symplify/easy-coding-standard": "^11.1", "thecodingmachine/phpstan-safe-rule": "^1.2" }, "suggest": { "ext-bcmath": "For better performance (or GMP)", "ext-gmp": "For better performance (or BCMath)", "ext-openssl": "For OpenSSL based cyphering" }, "type": "library", "autoload": { "psr-4": { "SpomkyLabs\\Pki\\": "src/" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Joni Eskelinen", "email": "jonieske@gmail.com", "role": "Original developer" }, { "name": "Florent Morselli", "email": "florent.morselli@spomky-labs.com", "role": "Spomky-Labs PKI Framework developer" } ], "description": "A PHP framework for managing Public Key Infrastructures. It comprises X.509 public key certificates, attribute certificates, certification requests and certification path validation.", "homepage": "https://github.com/spomky-labs/pki-framework", "keywords": [ "DER", "Private Key", "ac", "algorithm identifier", "asn.1", "asn1", "attribute certificate", "certificate", "certification request", "cryptography", "csr", "decrypt", "ec", "encrypt", "pem", "pkcs", "public key", "rsa", "sign", "signature", "verify", "x.509", "x.690", "x509", "x690" ], "support": { "issues": "https://github.com/Spomky-Labs/pki-framework/issues", "source": "https://github.com/Spomky-Labs/pki-framework/tree/1.1.0" }, "funding": [ { "url": "https://github.com/Spomky", "type": "github" }, { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2023-02-13T17:21:24+00:00" }, { "name": "symfony/deprecation-contracts", "version": "v3.3.0", "source": { "type": "git", "url": "https://github.com/symfony/deprecation-contracts.git", "reference": "7c3aff79d10325257a001fcf92d991f24fc967cf" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/7c3aff79d10325257a001fcf92d991f24fc967cf", "reference": "7c3aff79d10325257a001fcf92d991f24fc967cf", "shasum": "" }, "require": { "php": ">=8.1" }, "type": "library", "extra": { "branch-alias": { "dev-main": "3.4-dev" }, "thanks": { "name": "symfony/contracts", "url": "https://github.com/symfony/contracts" } }, "autoload": { "files": [ "function.php" ] }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Nicolas Grekas", "email": "p@tchwork.com" }, { "name": "Symfony Community", "homepage": "https://symfony.com/contributors" } ], "description": "A generic function and convention to trigger deprecation notices", "homepage": "https://symfony.com", "support": { "source": "https://github.com/symfony/deprecation-contracts/tree/v3.3.0" }, "funding": [ { "url": "https://symfony.com/sponsor", "type": "custom" }, { "url": "https://github.com/fabpot", "type": "github" }, { "url": "https://tidelift.com/funding/github/packagist/symfony/symfony", "type": "tidelift" } ], "time": "2023-05-23T14:45:45+00:00" }, { "name": "web-token/jwt-core", "version": "3.2.8", "source": { "type": "git", "url": "https://github.com/web-token/jwt-core.git", "reference": "2bc6e99a60910d0f495682acd8b23d3eef9865a3" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/web-token/jwt-core/zipball/2bc6e99a60910d0f495682acd8b23d3eef9865a3", "reference": "2bc6e99a60910d0f495682acd8b23d3eef9865a3", "shasum": "" }, "require": { "brick/math": "^0.9|^0.10|^0.11", "ext-json": "*", "ext-mbstring": "*", "paragonie/constant_time_encoding": "^2.4", "php": ">=8.1", "spomky-labs/pki-framework": "^1.0" }, "conflict": { "spomky-labs/jose": "*" }, "type": "library", "autoload": { "psr-4": { "Jose\\Component\\Core\\": "" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Florent Morselli", "homepage": "https://github.com/Spomky" }, { "name": "All contributors", "homepage": "https://github.com/web-token/jwt-framework/contributors" } ], "description": "Core component of the JWT Framework.", "homepage": "https://github.com/web-token", "keywords": [ "JOSE", "JWE", "JWK", "JWKSet", "JWS", "Jot", "RFC7515", "RFC7516", "RFC7517", "RFC7518", "RFC7519", "RFC7520", "bundle", "jwa", "jwt", "symfony" ], "support": { "source": "https://github.com/web-token/jwt-core/tree/3.2.8" }, "funding": [ { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2023-08-23T09:49:09+00:00" }, { "name": "web-token/jwt-key-mgmt", "version": "3.2.8", "source": { "type": "git", "url": "https://github.com/web-token/jwt-key-mgmt.git", "reference": "3b51eeeff38ac58ee86ec83d073b88b8294b1c7e" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/3b51eeeff38ac58ee86ec83d073b88b8294b1c7e", "reference": "3b51eeeff38ac58ee86ec83d073b88b8294b1c7e", "shasum": "" }, "require": { "ext-openssl": "*", "php": ">=8.1", "psr/http-client": "^1.0", "psr/http-factory": "^1.0", "web-token/jwt-core": "^3.2" }, "suggest": { "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys", "php-http/httplug": "To enable JKU/X5U support.", "php-http/message-factory": "To enable JKU/X5U support.", "web-token/jwt-util-ecc": "To use EC key analyzers." }, "type": "library", "autoload": { "psr-4": { "Jose\\Component\\KeyManagement\\": "" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Florent Morselli", "homepage": "https://github.com/Spomky" }, { "name": "All contributors", "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors" } ], "description": "Key Management component of the JWT Framework.", "homepage": "https://github.com/web-token", "keywords": [ "JOSE", "JWE", "JWK", "JWKSet", "JWS", "Jot", "RFC7515", "RFC7516", "RFC7517", "RFC7518", "RFC7519", "RFC7520", "bundle", "jwa", "jwt", "symfony" ], "support": { "source": "https://github.com/web-token/jwt-key-mgmt/tree/3.2.8" }, "funding": [ { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2023-05-18T16:20:51+00:00" }, { "name": "web-token/jwt-signature", "version": "3.2.8", "source": { "type": "git", "url": "https://github.com/web-token/jwt-signature.git", "reference": "156e0b0ef534e53eecf23a32a92ee6d8cb4fdac4" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/156e0b0ef534e53eecf23a32a92ee6d8cb4fdac4", "reference": "156e0b0ef534e53eecf23a32a92ee6d8cb4fdac4", "shasum": "" }, "require": { "php": ">=8.1", "web-token/jwt-core": "^3.2" }, "suggest": { "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms", "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms", "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms", "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms", "web-token/jwt-signature-algorithm-none": "None Signature Algorithm", "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms" }, "type": "library", "autoload": { "psr-4": { "Jose\\Component\\Signature\\": "" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Florent Morselli", "homepage": "https://github.com/Spomky" }, { "name": "All contributors", "homepage": "https://github.com/web-token/jwt-signature/contributors" } ], "description": "Signature component of the JWT Framework.", "homepage": "https://github.com/web-token", "keywords": [ "JOSE", "JWE", "JWK", "JWKSet", "JWS", "Jot", "RFC7515", "RFC7516", "RFC7517", "RFC7518", "RFC7519", "RFC7520", "bundle", "jwa", "jwt", "symfony" ], "support": { "source": "https://github.com/web-token/jwt-signature/tree/3.2.8" }, "funding": [ { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2023-05-18T16:20:51+00:00" }, { "name": "web-token/jwt-signature-algorithm-ecdsa", "version": "3.2.8", "source": { "type": "git", "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git", "reference": "34b119d6b5eca53914ad3b96660e5bd7fb5538b9" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/34b119d6b5eca53914ad3b96660e5bd7fb5538b9", "reference": "34b119d6b5eca53914ad3b96660e5bd7fb5538b9", "shasum": "" }, "require": { "ext-openssl": "*", "php": ">=8.1", "web-token/jwt-signature": "^3.2" }, "type": "library", "autoload": { "psr-4": { "Jose\\Component\\Signature\\Algorithm\\": "" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Florent Morselli", "homepage": "https://github.com/Spomky" }, { "name": "All contributors", "homepage": "https://github.com/web-token/jwt-framework/contributors" } ], "description": "ECDSA Based Signature Algorithms the JWT Framework.", "homepage": "https://github.com/web-token", "keywords": [ "JOSE", "JWE", "JWK", "JWKSet", "JWS", "Jot", "RFC7515", "RFC7516", "RFC7517", "RFC7518", "RFC7519", "RFC7520", "bundle", "jwa", "jwt", "symfony" ], "support": { "source": "https://github.com/web-token/jwt-signature-algorithm-ecdsa/tree/3.2.8" }, "funding": [ { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2023-05-18T16:20:51+00:00" }, { "name": "web-token/jwt-util-ecc", "version": "3.2.8", "source": { "type": "git", "url": "https://github.com/web-token/jwt-util-ecc.git", "reference": "b2337052dbee724d710c1fdb0d3609835a5f8609" }, "dist": { "type": "zip", "url": "https://api.github.com/repos/web-token/jwt-util-ecc/zipball/b2337052dbee724d710c1fdb0d3609835a5f8609", "reference": "b2337052dbee724d710c1fdb0d3609835a5f8609", "shasum": "" }, "require": { "brick/math": "^0.9|^0.10|^0.11", "php": ">=8.1" }, "suggest": { "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance", "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance" }, "type": "library", "autoload": { "psr-4": { "Jose\\Component\\Core\\Util\\Ecc\\": "" } }, "notification-url": "https://packagist.org/downloads/", "license": [ "MIT" ], "authors": [ { "name": "Florent Morselli", "homepage": "https://github.com/Spomky" }, { "name": "All contributors", "homepage": "https://github.com/web-token/jwt-framework/contributors" } ], "description": "ECC Tools for the JWT Framework.", "homepage": "https://github.com/web-token", "keywords": [ "JOSE", "JWE", "JWK", "JWKSet", "JWS", "Jot", "RFC7515", "RFC7516", "RFC7517", "RFC7518", "RFC7519", "RFC7520", "bundle", "jwa", "jwt", "symfony" ], "support": { "source": "https://github.com/web-token/jwt-util-ecc/tree/3.2.8" }, "funding": [ { "url": "https://www.patreon.com/FlorentMorselli", "type": "patreon" } ], "time": "2023-02-02T13:35:41+00:00" } ], "packages-dev": [], "aliases": [], "minimum-stability": "stable", "stability-flags": [], "prefer-stable": false, "prefer-lowest": false, "platform": [], "platform-dev": [], "plugin-api-version": "2.6.0" }